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How to import data
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TINTRODUCTION
With the introduction of Qlucore Omics Explorer version 3.3 the program can be configured with
separate modules. One module — the NGS module — was introduced with version 3.3.

This document covers the import functionality of the Qlucore Omics Explorer base module.

2 SUPPORTED DATA FORMATS/ARRAYS
This section applies to experiment data. Other sections will cover import of annotations and system
biology related information such as gene sets and pathways.

Qlucore Omics Explorer (OE) supports direct import of experiment data including normalization for

o Affymetrix 37 and WT arrays.

e Agilent mRNA arrays

e Agilent microRNA arrays

e Aligned BAM files with RNA-seq data

For lllumina data the recommended workflow is to normalize data with the GenomeStudio or
BeadStudio software and then use the Wizard in Qlucore Omics Explorer.

For data generated with other arrays/instruments or resulting from other type of sources, Qlucore
offers a wide range of import alternatives. If data is stored in a .txt, .csv or tsv file the Import Wizard,
see chapter 5, is a useful tool for efficient data import. If you are uncertain of how your data is
structured the Wizard is normally the best way to import data.

In total 10 different data set file formats are supported in the Qlucore Omics Explorer base module:

e} Affymetrix CEL files (.cel)

o) Affymetrix Probe Set Files (.chp)
o) Agilent Text Files (.txt)

e} Agilent Gene View files (.txt)

o) Simple Data Files (.txt)

o) BAM files ((bam)

e} Qlucore Data Files (.gedata)
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o) GEO Data Sets (.soft and .soft.gz) )1

o GEO Series Matrix (.txt and .txt.gz) 2

o) Compact Text Files (.txt; .csv)

o) BioArray Software Environment Files (.base)

3 HOW TO LOAD AND OPEN FILES
Files are loaded by using the File->Open menu. Then there are different filters that you can select.
See the picture below. Note that the picture might vary slightly depending on your operating system.
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Qlucore Data (*.gedata)
Affymetrix Probe Set (*.chp)
Affymetrix Probes (*.cel)

It is also possible to load both variable and sample annotation files, see chapter 10.

1,2 Note that it is only Data Sets from Gene Expression Omnibus in these formats that are supported.
Not just any *.soft or *.soft.gz file.
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4 AFFYMETRIX FILES
This applies to mMRNA array based data. For miRNA data only normalized data is accepted and the
suggested workflow is to import the normalized data using the Wizard, see section 6.

4.7 AFFYMETRIX CEL FILES (.CEL)
The import and normalization will normally include four steps

1. Select files

2. Select normalization method

3. Select which annotations to import
4. Inspect the QC-report

To start the import: Select File->Open and select the files you would like to open. To select multiple
files use the shift key on the keyboard.

The data import process includes downloading information about the array from Affymetrix server.
You need to be connected to Internet if you do not have this data stored locally.

After a short while you are asked to select normalization method. Three methods are provided

[¢) RMA
o) RMA Sketch
e} Plier

The next step is to download annotations from the Affymetrix NetAffx server 3 You can select which
annotations to include in your data set.

Finally the QC-report is displayed.

In OE, normalization and summarization will be performed on gene (transcript level) both for 3”
arrays and WT arrays.

34 This requires that the user is registered at the Affymetrix website. See chapter Error! Reference
source not found. for more information about downloading from the Affymetrix website.
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4.2 AFFYMETRIX PROBE SET FILES (CHP)

Select File->Open and select the files you would like to open. To select multiple files use the shift key
on the keyboard.

You will be asked if you would like to download annotation data from Affymetrix NetAffx server
automatically"’. When loading probe set annotations from Affymetrix Whole Transcript arrays, such
as Human Gene 1.0 ST, Omics Explorer automatically creates simplified annotations (Gene Symbol,

Gene Title,...) in addition to the annotations in the Affymetrix annotation file. This makes it easier to
interpret the results and to search for interesting genes.

5 AGILENT FILES

5.7 AGILENT TEXT FILES

Omics Explorer can import text files created with Agilent Feature Extraction Software. These files
contain one array (sample) per file.

How to open Agilent text files

Select the File-Open menu item.

Select the Agilent Text File (*.txt) file filter.

Select the files and press Open. (Normally you select several files.)

In the Normalization Dialog, select a preprocessing scheme by pressing one of the four quick setting

buttons.

0 One-color mRNA
0 One-color miRNA
o) Two-color mRNA
o) Two-color miRNA

Instead of using the above quick settings, you can select your own customized preprocessing. See
the OE reference manual, section “Agilent .txt files”, for details.
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52 AGILENT GENEVIEW FILES (TXT)

Qlucore Omics Explorer can open Agilent GeneView files. These files contain miRNA expression
levels. They are created with the Agilent Feature Extraction Software. Each file contains data from a
single array. To select multiple files use the shift key on the keyboard.

Normalization

The data is normalized as recommended by Agilent:

'} thresholding
e} 2-logarithm
o) percentile shift (optional, but recommended)

You can select the threshold value and the percentile. Recommended values are threshold = 1.0 and
percentile = 75.

6 ALIGNED BAM FILES
You can import and Normalize RNA-seq data in the form of an aligned BAM file.

Select the File - Open BAM files menu item.

Use the Add button to select individual files.

Or use the Add Folder button to select all BAM files in a folder recursively.

Press OK to start loading the selected files. This can take a while.

Please note that the BAM files have to be sorted by coordinate.

A GTF (Gene Transfer Format) file is needed to describe where the genes are located in the
reference genome. file. GTF files can be downloaded from ftp.//ftp.ensembl.org/pub/current gtf/.

7 IMPORT WIZARD
The OE Import Wizard supports import of normalized data in many different formats. The starting
point is that data is stored in a file with extension .txt, .csv or .tsv.

The samples can be in one or multiple files. If the samples are in multiple files the file format for all
samples must be identical. You reach the Wizard by the menu File->Open with Wizard.

The Wizard guides you through 8 steps where you define how the layout of the data shall be
interpreted and imported. The Wizard can for example handle

o} Samples in multiple files
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'} Samples as columns and variables as rows, or the transposed version
o) Various data separators [*,”, *;”, “tab” or other]

'} Data on every ith column or every ith row.

o File header or not

o Data that shall not be imported

'} Various indications of missing values [empty cell, n/a, NA,...]

0 Annotations

If you are uncertain of how your data is structured then the Wizard is the best option for data
import.

Note: The Import Wizard is an automatic import method for very many different types of files. Make
sure to verify that the import results in the expected number of samples and variables.

8 QLUCORE DATA FILES (.GEDATA)

The Qlucore Data file format has been designed to make it easy to create a file by copying and
pasting in a spread sheet application. Data resulting from other tools and applications can easily be
formatted and imported into Qlucore Omics Explorer using this file format. A Qlucore Data File
contains a complete data frame, including sample and variable annotations. °

There are three important things to note when a file shall be created

1. It is a tab-separated text file.
2. The file shall have the file name extension .gedata.
3. Data shall be formatted as described below

5 A Qlucore data file does not contain information about the colors used to represent the values of a
sample attribute in a plot, or the default variable annotation used when matching variable name lists
with variable annotations in the data frame. That information is stored in supplementary data files.
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8.1 HOW TO CREATE A QLUCORE DATA FILE
There are several ways to start the creation of the data file (.gedata).

a) If you have installed OE on your computer you can create a new data file template by right

clicking on your desktop and selecting New and Qlucore Omics Explorer. This will generate a new file @
on your desktop. If your right click on the new file you can open the file with Excel or another )
spreadsheet application. Then you need to copy and paste data from your original data file into the

new file. A guide on how to do this follows below in the section Formatting.

b) Open up your original data file and include rows and columns as described in the section
Formatting.

8.1.1 FORMATTING

Copy and paste the data into the spreadsheet, following the layout below. You can use any
spreadsheet application, such as Excel or OpenOffice. When you are done and have formatted data
as below, go through the following three steps.

1. Select ‘Save as’ in the spread sheet application
2. Save the spread sheet as a tab delimited text file.
3. Rename the file by changing the file name extension from the default .txt to .gedata.

812 LAYOUT
The layout of the spreadsheet is best explained through an example. The data below contains

1. The measured data (cells are blue)

2. Sample annotation IDs: Array 1D, Age, Sex (cells are pink)

3. Sample annotations (cells are yellow)

4. Variable annotation IDs: VarlD and Symbol (cells are light blue).
5. Variable annotations (cells are green)
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We use the following data frame:

Array ID 5301 5302 5303 5304
Age 34 22 47 41
Sex Female Male Male Female

VarlD Symbol
3140 MR1
622 BDH1
7551 ZNF3
1537 cyci
961 CD47
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In a spread sheet application, this data frame should be arranged as follows:

Qlucore |gedata |version 1.0
4 samples |with 3 attributes
5 variables \with 2 annotations
Array ID 5301 |5302 5303 5304
Age 34 22 47 |41
Sex Female Male Male |Male
varID  [Symbol
A | | |
o won |
Gl | | [
S | | [
oo
|

Always
included

Note that the start of the file shall include the text and information as indicated by row 1to 5 in
the example above.

For your own data you need to adjust the number of samples, variables and annotations.
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813 TRANSPOSED DATA
The example given above has samples as columns and variables as rows. For some data it is more
natural to have the opposite, i.e. samples as rows and variables as columns.

Qlucore OE is capable to import .gedata files with data organized in this way if the word “transposed”
is added to cell D1, see the table below. Note that the table is not complete.

Qlucore gedata version 1.0 |transposed
5 samples with 2 attributes
4 variables |with 3 annotations
Variable ID 101 102 103 104

9 SIMPLE DATA FILE
The simple data file is a tab separated text file with the extension .txt.

The table below shows how data and identifiers should be organized. The rows are variables and the
columns are samples. The first column should include a unique variable identifier (green cells) and the
first row a unique sample identifier (yellow cells). Data is stored in the blue cells.

‘5301 ‘5302 ‘5303 ‘5304

a | | [ |

= [

= [

=7

< [
L
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If there is a text in the upper left cell, that information will be used as the variable annotation header,
otherwise the name will be Variable ID. The sample annotation header, corresponding to the sample
annotation in the first row, will be the Sample ID.

Normally you would like to complement your data import with annotations, see chapter 10.

10 COMPACT TEXT FILE (.CSV)

Omics Explorer supports compact text files. These contain data, sample annotations and variable
annotations for multiple samples in a single file. If compared to a “.gedata” file, see chapter 7, the
compact text file is lacking a file header and has samples as rows. The layout of the files is described
below. The last variable annotation (in the example below the second row) will be used as variable id.
Note that the name of this annotation is not included in the file; after loading the file the annotation
will be called Variable Id.

The file can have either the extension “.txt” or “.csv”. Both options work.

Symbol  ENC1 CDK8 PEX7 SNN DLX6

Array | Age Gender 201314 _at 204831_at 205420_at 218032_at 221289 at

How to open a compact text file

Select the File - Open menu item.

Select the file and press Open.

If the file contains only one variable annotation you will be asked to enter the index of the first data
column (in the example above it is column 4).
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11 LOAD ANNOTATIONS
Annotations are information about your samples and variables.

1.1 FROM A .TXT OR .CSV FILE

You can add sample and variable annotations to an existing data set by importing an annotation text
file. These files are tab- or comma-delimited text files. The file name extension is .txt if the file is tab-
delimited and .csv if the file is comma-delimited.

How to import a sample/variable annotation text file

Select the File - Import — Sample Annotations or the File - Import - Variable Annotations menu
item.

Select the Tab-separated Text (*.txt) or the Comma-separated Text (*.csv) file filter.

Select the file and press Open.

Select the annotations you want to import and press OK.

When importing an annotation text file, the samples/variables in the file will be matched with the
samples/variables in the data frame using the annotation in the first column of the annotation file and
the sample/variable ID annotation in the data set (This can be changed in the Data tab). In this way
the ordering of the rows in the annotation file and the data frame does not matter.

1.2 CREATE A SAMPLE/VARIABLE ANNOTATION TEXT FILE

Place the data in a spreadsheet, following the layout below. You can use any spreadsheet application,
such as Excel or OpenOffice. Save the spreadsheet as a tab- or comma-delimited text file. Use the file
name extension .txt if the file is tab-delimited and .csv if the file is comma-delimited. We recommend
using tab-delimited text files.

The following layout should be used:

Probe Set Transcript Gene Symbol Chromosome | Entrez Gene
1007_s_at u48705 DDR1 chrép21.3 780
1053_at M87338 RFC2 chr7q11.23 5982
117_at X51757 HSPA6 chrlg23 3310

121 at X69699 PAX8 chr2ql2-q14 7849

1255 g at L36861 GUCA1A chrép21.1 2978

1294 g at L13852 UBA7 chr3p21 7318
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The first row contains the name of each annotation. Each of the remaining rows contains the value of
each annotation for one sample/variable. The first column should contain an annotation that matches
the sample/variable ID in the data set.

This table should be saved as a tab-separated text file with file name extension .txt or as a comma-
separated text file with file name extension .csv.

1.3 FROM NETAFFX
You can download variable annotations for Affymetrix arrays from the Affymetrix NetAffx server and
add them to the data set.

The downloaded annotation files will be stored on your computer, and can be used without having to
download them from the server again. When you select to download annotations, you will be notified
if updated annotations are available on the Affymetrix server.

When downloading probe set annotations for the Affymetrix whole transcript arrays, Omics Explorer
will create simplified annotations (Gene Symbol, Gene Title,...) in addition to the annotations in the
downloaded annotation file.

How to download and import annotations from the Affymetrix NetAffx server ©

Select the File — Download- Affymetrix Probe Set Annotations menu item.

Select the array type and press OK .

Select the annotations you want to import and press OK.

12 R USERS
In the FAQ section, on the support pages. on www.glucore.com, a script for data conversion is
available. This script converts data in R to a .gedata file. More information is provided in the FAQ.

13 NGS DATA

With the NGS module can a rich suite of different NGS related files be improted and pre-processed
to build up a NGS project. Details are presented in the Documentation and Help system that is
shipped with the program.

6 The first time you use this function, you will also be asked to provide: your Affymetrix user name
and your Affymetrix password and the folder where the downloaded annotation files will be stored. If
you do not have an Affymetrix user name and password you can get one by pressing the Register
button. This will take you to the registration page on the Affymetrix web site.
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TERMINOLOGY
Samples: We use samples to describe units such as patients, persons, animals, treatments, dates,...

Variables: We use variables to describe quantities that have been measured for each samples, such as
Gene Expression Levels, Protein concentrations, answers to a question in a questionnaire,...

Annotation: A description of a sample or a variable. One sample or variable can be described by one
or many annotations.

DECIMAL POINT AND DECIMAL COMMA
Both separators are supported in all tab separated .txt files and .csv files.

DISCLAIMER
The contents of this document are subject to revision without notice due to continuous progress in
methodology, design, and manufacturing.

Qlucore shall have no liability for any error or damages of any kind resulting from the use of this
document.

Qlucore Omics Explorer is only intended for research purposes.

TRADEMARK LIST
Excel, Windows Vista, Windows 7 and Windows 10 are either registered trademarks or trademarks of
Microsoft Corporation in the United States and/or other countries.

NetAffx is the trademark of Affymetrix.

GenomeStudio and BeadStudio are trademarks of Illumina
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